[401] Not Authorized - Asana Integration

Hello Everyone,
I had a scenario being triggered by a webhook that was setting up an Asana project. It was working fine and then when tried to test some things today, it’s randomly throwing a [401] Not Authorized error. If I just force the webhook through again, the error appears at different asana stages. Sometimes it happens right away, and other times it happens dozens of operations in.

I’ve tried resetting and reverifying the connection, but nothing has fixed it. The randomness of the error showing up has me really confused. Asana’s rate limits for my plan are way higher than my operation count, so I don’t think that’s the problem.

Any ideas on what else I might try or what may be causing the problem?

Hi @Michael_Wilson welcome to the community :wave:

Thanks so much for raising this issue here! The devs are currently working on fixing this and on deploying the changes as soon as possible.

I’m very sorry for any headache this has brought to you. I’m keeping an eye on this and I’ll make sure to post an update here once all’s back to normal. Thanks for your understanding and for your patience :pray: