[SOLVED] Data store problems - Writing to data store does not work in scenario but separately yes

Edit: Solved. For some reason all data was overwritten even this “Overwrite an existing array in the record” was NO. Weird. I checked all update a record data store modules and now tests go 100% OK.


Let’s try this community first time.

My scenario worked over a year but last night problems started arising.

Writing to data store don’t work anymore. Doing some tests and running data store module itself, writing does work.

I don’t understand what is the problem. I will continue to search solution but if you could suggest me where to look…

Data store does not give any errors.



Welcome to the Make community!

Could you please share screenshots of the module fields and filters in question? It would really help other community members to see what you’re looking at.

You can also export the scenario blueprint file to allow others to replicate the issue. At the bottom of the scenario editor, you can click on the three dots to find the Export Blueprint menu item.


Uploading it here will look like this:

blueprint.json (12.3 KB)

If possible, could you also please provide the input/output bundles of the modules by running the scenario, then clicking the bubble on the top-right of each module, taking screenshots of, and copying the contents into this discussion thread:


This will allow others to better assist you. Thanks!


Sorry mate that i didn’t send bluprint. My scenario is quite well documented so it takes time to cover all customer related things. I did check it tho :grin:

Thanks anyway!

A post was merged into an existing topic: :rotating_light: Data Store issues: Update record erases fields that were left empty

I can confirm the strange and unexpected behaviour of the Data Store modules, we’re waiting for the Support to respond.

Similar issue for us: Update Record module was overwriting (erasing, effectively) the fields that were left blank in it, even though it worked as expected (only affecting the fields that were explicitly mentioned in the module) for more than 2 years now.

Looks like an accidental issue, maybe a technical update went wrong or smth. Still, it’s dangerous, because it erases data from Data Stores, and partially restoring those from backups is a whole thing in itself…

Hi everyone @here

I just wanted to quickly step in and let you know that this is a known issue on our end and that our devs are working towards deploying a fix as soon as they can.

Whenever I will learn any updates about this, I will make sure to post them into this thread:

For updates, you can also

I am really sorry for the trouble this is causing you. Thank you very much for your understanding and for bearing with us :pray: