404 Error when creating Github connection

Hi all! Going to use the handy template here:

:footprints: The steps you have taken

  1. Log in to my Github account
  2. Go to Settings > Developer Settings > OAuth Apps >Add new App
  3. Generate a Cient Secret for the new application
  4. Back in Make, add the ‘Get a File’ module into a scenario
  5. Attempt to add a new Connection to Github
  6. Add the Client ID and Client Secret from my github app
  7. Click Save, hit a 404 page
  8. Close the page, and see a 401 error in Make
  9. Be sad, try several variations, then eventually post here

:camera_flash: Relevant screenshots
Github’s 404 (with some details on the attempted URL):

Settings when trying to create/authorize a new App in github:

:link: Any links you have
Github’s 404

Any thoughts or recommendations are appreciated!

I have having this same issue.

Github may have broken the way Make’s previous authorization flows worked when they introduced the new “fine-grained tokens” currently in beta. The result of this is what were originally just referred to as "“tokens” are now “classic tokens”.

If this is the case, Make needs to update the authorization flow to point to the proper location.


Thanks so much for this context, and for validating that it’s not just meee facing this!

Given this auto-response to a recent ticket, this may not be high on the priority list, unfortunately:

Hey Team!

We all know that Rebranding is sucks :slight_smile: It takes a crazy amount of time out of your schedule already.

Since so many automations have been frozen due to the leak of GitHub integration, could you please make this prior to anything else if it is possible within your flow?

1 Like

@here Heya everyone and welcome to those of you who have just joined the community :wave:

I just wanted to jump in here to say thank you for bringing this up. I asked around and it turns out that our devs are aware of the issue and working on fixing it. Hopefully, all will be up and running as soon as possible.

I know that this is frustrating and I’m really sorry for the headache this is causing you. I’ll keep an eye on this and make sure to post an update here once I learn any news related to this issue.

Thanks for your understanding and for bearing with us :pray:


Thank you @Michaela! Happy to hear some update on this.

1 Like

Thank you so much for the quick response. Looking forward to hearing from you.

1 Like

Hello everyone @here

The issue should be fixed and all should be back to normal. You can test it out for yourself and let me know if everything’s working for you.

Thanks again for your patience and for your understanding :pray:

Nope, still showing the exact same behavior.

I tried both without a ClientID and with my own ClientID.

Without ClientID (as it should be):

With my own ClientID (as a secondary test):

@UncleTallest Unless you’ve registered your own oAuth2 application within Github (correctly) you should not fill in any client_id or secret.
Make will take care of this, you only have to authorize it (without advanced settings).

I tried without as well. It’s in the images in my last post.

Thanks for letting me know that this issue still prevails, @UncleTallest

I’m really sorry for having raised your hopes too early. Turns out that there are still some bits that need to be dealt with. Sorry again and I swear the next time I’m announcing this as fixed, it’ll be for real.

Thank you for bearing with us, I really appreciate your patience.


Hello team! any updates on this one yet?

One possible solution could be to register a new oAuth2 application within GitHub and correctly authorize it without using advanced settings. Alternatively, the issue may be caused by a problem with the client ID or secret being used, in which case verifying and correcting these details could resolve the issue.

It’s even worse for me: I get an error as soon as I click the Add button:


Hey folks, just wanted to give you a quick update on this. Our devs have identified and fixed the issue and are now testing everything to make sure that all works the way it’s supposed to before deploying the fixes to production. As soon as that happens, I’ll make sure to let you all know here.

Sorry that this is taking time and thanks so much for your patience on this one :pray:

1 Like

Thanks a lot for the update @Michaela! That sounds like great news. Please can you clarify whether the similar error I posted above will also be fixed, or just the 404 originally reported?

Hi @aspiers, we tried to reproduce this issue on our end but were not successful.

This does, however, look like a browser issue. Could you please try

  • logging in and out of Make
  • clearing your cache and cookies
  • opening your scenario in a different browser

and see if you’re still getting that error when trying to add your connection?

Thank you :pray:

I can’t reproduce it either now. Don’t think I even needed to do any of your suggestions, must have been a weird glitch.

Now I’m getting the same 404 as everyone else. However I noticed that the OAuth window created for the authorization flow had the following URL in the address bar:

https://github.com/login/oauth/authorize?scope=repo&client_id=&redirect_uri=https%3A%2F%2Fwww.integromat.com%2Foauth%2Fcb%2Fgithub&response_type=code&state=<censored to be safe>

Notice how client_id is empty here. And indeed I see exactly the same thing in the URL from the screenshot in @UncleTallest’s above post where he’s trying without specifying a ClientID.

However Authorizing OAuth Apps - GitHub Docs says that this parameter is required. So surely that can’t be right if it’s empty?

Hi everyone @here

I know this took a while and I’m really sorry for the wait but the devs have deployed the fix and all should be up and running again.

Feel free to test this and let us know if things are working for you.

Thanks for being patient with us :pray: