Access blocked: integromat.com has not completed the Google verification process

I’m trying to create a connection to my Google Drive. I followed all the steps Connecting to Google services using custom OAuth client (make.com)
image

Not sure why I’m getting this still.

Welcome to the Make community!

You have to set up your own custom GCP OAuth app.

How to create an OAuth app in GCP: https://www.make.com/en/help/tutorials/calling-google-apis-via-the--http-make-a-oauth-2-0-request--module ← FOLLOW THIS

1a. Enable the relevant API

Find the relevant API here: Google Cloud console
Go to API page, end click “Enable”

1b. Add the relevant scopes

Direct Link: https://console.cloud.google.com/apis/credentials/consent/edit

2. Insert all the known Google Redirect URIs for your app

Direct Link: https://console.cloud.google.com/apis/credentials

Here are some known redirect URIs you need for your Google Cloud Console OAuth app. If you set these up, you can reuse the same GCP app for other Google apps and modules on Make.

Once you’ve set these up, you can use/reuse the same Make connection for all the supported Google apps & modules on Make - you’ll only have to enable the APIs for your custom app.

3. Publish your GCP OAuth2 app

Direct Link: https://console.cloud.google.com/apis/credentials/consent

You might need to set your OAuth application to “Production”, otherwise the credentials expire very frequently.

1. To do this, go to menu item “OAuth consent screen”

or click here https://console.cloud.google.com/apis/credentials/consent

2. Then click the button below if the Publishing status is not “In production”

4. Set up connection (HTTP OAuth, or respective Google App)

A. HTTP OAuth2

You need a “Authorize parameters” key of redirect_uri with the above Make OAuth2 callback URL.

You can find the Client ID and Client Secret in the OAuth2 app you created in GCP, on the right-hand side of where you inserted the 8 callback URLs in step 2:

B. Google App

Insert the GCP app client ID and secret here BEFORE clicking “Sign in”
Gmail example:

samliewrequest private consultation

Join the unofficial Make Discord server to chat with other makers!

1 Like

I’ve tried this like 15 times. I’ve done the HTTP Module version, and the using the Google Drive module. I even created a new project in my Google Cloud console, new OAuth, new credentials. I’m still getting an error. But this time it not 403. It’s now redirect_uri_mismatch

image

1 Like

same is coming for me