Cannot select data to write, but shows its in the read array?


Background: I’m tring to automate adding my business cards from people, by scanning them in via Contact+ and inputing them into Clickup.

Issue: It seems the office number is missing when trying to write it.

Bit of a novice however it seem when I try and write data to Clickup in the field it doesn’t give me the option to use the “office number”, but when I read it in from Contacts+ it shows it too me. I can only choose one option. Please see attached screen shots. One shows the data is being read into Make. Other doesn’t give me the option. This is the same when I use the Get Variable module.

Seems like a bit of a bug.

I’m I doing something wrong?


Hi @Mit , I can see there are two phone numbers in one array. I will suggest using the get() function to obtain the work/mobile phone number from the array.

Get the first number:
{{get(map(PhoneNumber; “value”); 1)}}

Get the second number:
{{get(map(PhoneNumber; “value”); 2)}}

Replace the PhoneNumber to your PhoneNumber array.

Hope it helps :slight_smile:

1 Like

Hi Libin,

Thank you very much.

When you say replace phone number with array, what do you mean please?

Do you mean in the clickup field I want to use it, I need to use {{get(map(PhoneNumber; “value”); 1)}}?

I’ll give it a go next week once back from holiday.

Learn the Get and Map function from here; you will be able to do it yourself.


Hi @Mit

I have circled the PhoneNumber array on your screenshot, thats the array you can use in get(map(PhoneNumber; “value”); 1)}} function.

1 Like

Soted it, the above directly didnt work, it worked once I had clicked the array from the dropdown list.

The text that worked looked liked this {{get(map(13.contactData.phoneNumbers; “value”); 2)}}
also the text value is not in quotation marks.

1 Like

Great video, thanks helped with my sitatuion. Thank you.

1 Like