Can't get the share link from Google Drive

Hey there Makers, I am pretty new to this UI and setup, I have managed to upload a file (mp3) to Google drive, i now believe I need the share link to get this file into Airtable.

Basically I am wanting to get the mp3 file into airtable so that I can upload it to wordpress. I am stuck on the getting a share link part. I tried most of these and still get errors either a 403 or missing something

Welcome to the Make community!

I don’t see any errors in your screenshots.

What could it be?


Not sure but it could be that the particular file does not have share permissions when you are getting the link. You may need to update the permissions of the file. And then try again.

1 Like

Thanks guys, sorry for slow reply.

I am getting a 404 error for the share link.

I see the file name is correct.

Screenshot 2024-05-07 at 7.53.28 PM
Screenshot 2024-05-07 at 7.53.34 PM

I am going Airtable > Elevenlabs > Google Drive Upload > Google Drive Share a Link > Update Airtable (with hopefully the mp3)

Oh! You can’t use the file name variable in the Get a Share Link module.

The modules run on file ID – it’s in the variables panel somewhere. Do look at the full list to find it, or you can use the search panel at the top of the variables like to search for “ID”.

1 Like

ok cool i changed that and now it works, but I am not seeing the mp3 file in airtable. I actually saw it blink in the correct cell like it was doing something but nothing happened. From the output i see Data size: 2.8 KB


Validation failed for 1 parameter(s).

  • Array of objects expected in parameter ‘fldhQJJuz18G9y8mg’.

It seems to be failing on the last two modules or the last module in updating airtable with the MP3.

I’ve got it to ‘flash’ in airtable but that’s about it, it will blink with A then do nothing?

“flash of nothingness”
Screenshot 2024-05-08 at 5.07.26 PM

I checked the bundled output from airtable update module and the file it is now outputting will download for me if i paste it into the address bar, but for whatever reason that file doesn’t get uploaded (technically downloaded) to airtable from Google Drive. I am using
Where id is the Gdrive upload file id

ok solved it myself, issues where a mix actually, some of which were the Google Drive as it has restrictions and the one I was using had restrictions. The other issue is the sharelink and using the correct URL paths etc.

1 Like