chatGPT is erroring in 500 or 502

Whenever I try to create a chatGPT completion (connected to paid account and API with plenty of credits), the following error happens:

Above is a 500 error code, but when it errors it’s either a 500 or a 502.

Unfortunately, this sort of server error messages returned by OpenAI is quite unhelpful.

If you have the Make DevTool Chrome extension installed, you should be able to view the request and response headers and body from each module when you manually run the scenario.

From the Help Center article about the Make DevTool:

Make DevTool allows you to debug your Make scenarios in a completely new way. It adds an extra pane to the Chrome Developer Tools. Using this new debugger pane, you’re able to check all the manual runs of your scenario, review all the performed operations and see the details of every API call performed. It also brings a whole bunch of new opportunities for Apps development. You’re able to check every call that your app has performed. Thanks to this extension, you can easily debug your scenario, see which module, operation, even which single response causes the error, and then get your scenario back on track. Try it out and let your scenarios shine!

For more information on how to install and use this, see

Alternatively, it might just be a temporary glitch on their (OpenAI’s) end. You can try again later, or delete and remake your connection to OpenAI and see if that helps.


@samliew Here’s what I get from Make DevTool:

Doesn’t really tell me anything useful though. What do you think?

I just tried verifying the connection and it seems fine.

I just tried deleting the connection, and then created a new one to chatGPT, and updated the instances of it in the scenario, but to no avail. Same problem.

Good morning,

in general 5XX errors are server side and out of your control. This specific error has been happening from time to time with chat gpt. Usually you should try again at a later time and it will be resolved.

There was a short API outage yesterday related to the API authentication, maybe this was at the same time you got the error? You can track the open ai server status here:


The first thing I checked was the OAI status page. The page doesn’t get updated until someone from the company manually posts an update, so sometimes it appears fine when it isn’t.


Thanks folks!
Yup! It’s now working again. Turns out it was an issue on their side after all.
Strange because chatGPT in the browser was working for me at the time, but could’ve been an issue specific to their API.

Thank you for your info on this. I’ll keep it in mind in the future.

Hello there @damirkotoric :wave:

Thanks a lot for circling back here and updating us on the situation :pray:

Good to hear that all’s back to normal and that you got some valuable pointers from @Stoyan_Vatov and @samliew. :clap:

1 Like