Date format when adding row in Excel table

Hi everyone,

I have a scenario that will add new rows to an Excel table everytime someone fills in my Tally form. One of the columns will add the completion time but whatever I try to do, the date is always filled in as text. Does anyone know how to return the date in a format Excel will recognise as a date instead of text?

If I don’t use any functions, Excel will insert the date as text in ISO 8601 format. If I use formatdate, it is in the format I choose but still as text.

Not sure it is something to do with type format of the column in the Excel table but I cannot seem to change it:

Hey @Oliver_Carvell-Smith ,

You need to change the Column Format in Excel. Currently, the column in Excel is in “Text” format.
Select the whole date column and click on the drop down arrow, as shown in the below image.

Click on “More Number Formats”

And now you can select the date format of your choice.

Do this, and then refresh the Excel module on make → then try to run the scenario.

Let me know if it works.

Hi @AnujP. Thanks for the response. I’ve tried that and refreshed the module but it’s still showing as text format unfortunately.

I’ve even tried creating a brand new table in a new file, added to a new scenario and the column type always returns as text

I’m having the same problem so would be really grateful for a solution.