Disable text field

Hi everyone, I’ve trying to disable a text field but am unable to do so. Here is how my mappable paramters looks like:

	"name": "type",
	"type": "text",
	"editable": false,
	"default": "text"

Even though I have added the editable: false, the field is still editable in the scenario builder. Also didn’t find anything related to this in the docs.

Any help would be highly appreciated.

Hi @developer ,

Can you explain a bit more about your use case? What’s the reason you would like to “disable” the input field?

Glenn - Callinetic

1 Like

Well, I don’t want users to change the default value that I have provided. I mean if there’s a better way to do this would be happy to implement it.

Consider this use case where I am getting that default value from an RPC and the API also requires that value, in that case I wouldn’t want users to be changing that value since it’ll throw an error from the API

According to the Custom Apps documentation for Parameters, you should use “disabled”.


editable” – is not used anywhere, and I’m not sure where you got this from.


Hi @developer ,

Thank you for the clarification. Should this detail be visible to the user? If not, you could set this parameter as “hidden” to conceal it within the UI, while still transmitting the default value to your service in the background.

Source: https://docs.integromat.com/apps/app-components/parameters/hidden

Glenn - Callinetic


I could be hidden yeah, but I was thinking is there any way to make it disabled, but yes it can be hidden and still serve the purpose.