Discord Role to a Guild Member - 403 error Missing permissions


I was using Discord module since few weeks without any issue to manage discord server members and deal with roles and access.

Since yesterday, I’m not able to “Add” or “Remove Role to a Guild Member” and I’m getting “The operation failed with an error. [403] Missing Permissions”.
Other Discords services are working (at least thoses I’m using).

Is anything change in Discord API / Or make script ? Am I the only one ?

I well rechecked role permission on discord side and I deleted and reconnected Make and Discord together … I’m lost.

Thanks for your support.


Solution found. :partying_face: !

Discord updated their policies : https://support-dev.discord.com/hc/en-us/articles/4404772028055

Discord API cannot be used anymore with standard connection in Make for privileged actions (Delete a message, change a role …).

Discord Developer account is needed and dedicated application have to be created with special settings selected:

More info: Discord Developer Portal

From Make side, advanced settings should be used to establish Discord Server access with all inputs fulfilled.

Good luck! :slight_smile:


Thanks so much for sharing the solution with the community @Nicolas_H, super helpful stuff :raised_hands:

Hey @Nicolas_H,

Sorry if this sounds dumb, I’m also getting this error just from having a user(bot) send a message.

Can you provide more details on how to cure this issue?

I actually don’t think this was the problem. Missing permissions is when you didn’t order Discord roles in the right hierarchy. I had the same issue and solved it this way…

Where is the advanced settings in the Make side? I couldn’t find it.

This is what worked for me.

I always wished that people wrote specific instructions on how to fix problems so here is an example.

I was getting 403 error Missing permissions

The channel in specific was private and the Integromat bot wasn’t a member of the channel. What I needed to do was add Integromat to the channel. Once that was done, the issue was fixed.

1 Like