Google Calendar - Creating a Task

My goal is to create a reminder (at a specific date and time) in my Google account.
I have created the required connections.

I have tried the Google Task module. While I successfully managed to create a Task, I could not set an alarm at a specific date and time.

Knowing that in Google Calendar, you can create Events, Tasks or Appointments, I tried the Google Calendar module. I can create an Event. No problem there.
But I can’t see an option to select the type of item (Event, Task or Appointment) in the module, and/or I can’t choose the “Task” calendar…
But how do I create a Task ?

What would be the best solution to create a reminder in my Google account ?
Ideally, I don’t want to create an event in my calendar, as I’d like the task to appear in the Tasks calendar…

Thank you for your help and suggestions !

Hey! I think I understand the problem. Here’s what you can do:

  1. Use Google Tasks to create a task module.

  2. Give the list ID and title of the task, and turn on Advanced options.

  3. There, you will be able to see a due date field.

  4. Set the specific date and time that you want to get a reminder.

Give this a try and let me know if it works for you.


Using the Google Tasks “Create a Task” module, you can use the Due Date field in the advanced settings.



Thank you both @samliew & @ThakurHemansh for your suggestion.
I have tried that, and while I was able to set the module correctly and get the scenario to run, the Task is created with a due date but no due time!

Looking at the details of the Task in Google calendar, I can see it is set as “All Day”.
(and even if I uncheck this, the original time is not preserved).

When looking at the bundle IN & OUT of the Create Task module, you can see the correct due date/time is sent in the INPUT (22/01/2024 13:16),
but the resulting OUTPUT says 22/01/2024 01:00 (which I’m assuming is midnight for my time zone, as I’m GMT+1).

As a result, the Task is set as ALL DAY…

Not sure what to do from there…

Looks like that’s a bug on the module then. You’ll need to contact support to fix it.

For quicker assistance with technical issues like these, you may want to contact support directly. They respond very quickly and update you frequently on the status of their investigation.

A temporary workaround will be to call the API endpoint directly using the “Make an API Call” module

1 Like

@samliew Thank you so much !
I will contact them.
And will implement the workaround is they can’t fix it in a timely manner (I haven’t used API calls yet, so if they can fix the module quickly, I feel that will be easier for me.)

Thanks again !