Google Gemini Location Error

Hi all

Trying to call Google Gemini through the API and getting a location error. I am assuming this is because my Make server is in the EU… any workarounds?

Data {
“error”: {
“code”: 400,
“message”: “User location is not supported for the API use.”,

The workaround is to use the Google Maps “Get a location” Module and pass the Formatted Address variable into Gemini.


Interesting!! :slight_smile: I added the module but how do I add this to the HTTP request?

Ohh I thought you wanted to get your location via Gemini.

So it looks like Gemini isn’t available for you. Not sure if there is even a workaround for this.

You can try ScrapeNinja to make the HTTP call – you can select different servers from there.


ah interesting ok thanks will look into that

Screenshot of module that shows US as a possible option



thats perfect now trying to figure out how the heck to get ScrapeNinja account lol… not easy

See RapidAPI Error Code 403 - #2 by samliew for screenshots


WOW there is NO way I would have figured that out. Thank you <3

So it seems I can scrape, but I cannot call the API from a proxy location?

how did you manage to connect it successfully? i keep getting an 403 error although i inserted the correct api key

What is the error message?


Looks like there is a stray / at the start of your URL, weird.

Try it with the ScrapeNinja sandbox ScrapeNinja Live Sandbox


Ok so that worked

Then I think I need to use the Scrape module coz I can choose US:

but it doesnt work

I think the headers are incorrect, since you are sending JSON.

Content-Type: application/json


Hi @KyleBehrend

Gemini is not supported in Europe. So please use Make organization with US Server.
This will solve your issue.

Unfortunately cannot change my server location, need to create a new account which sucks lo

1 Like

Yes, it is very unfortunate.