Google Sheets Connection

Hi All,

I have a simple scenario that is similar to ones I have created in the past. Basically, it looks for new rows in a google sheet, then updates a collection in Webflow with the information it finds.

I can connect to the Google Sheet when setting up the scenario, and it pulls the meta data with the column headers, which I use to link to various fields in the Make collection.

However, when I run the scenario, the google sheets icon just gets stuck in “Requesting Execution”. If I click on the Stop button, nothing happens. It doesn’t stop.

I have tried re-creating the scenario and the same thing happens. I have also let the scenario run for about 10 minutes so far, without any change.

Anyone have any ideas?

Thank you in advance,


EDIT: None of my other scenarios that connect to google sheets work now either. They worked in the past, but now… nothing.

When asking your question, please include:

:footprints: The steps you have taken
:camera_flash: Relevant screenshots
:link: Any links you have
[ Code { "and": "JSON", "in" : "code block"} ]
:x: Exclude Personal Information.

Solved: For some reason, it was a browser issue. I ran the scenario in another browser and it worked as expected.

Hi @AIJohn :wave:

Awesome to hear that you managed to resolve this by using another browser. Thanks a lot for circling back to your question and letting us know what did the trick for you :pray: