Google Sheets Search Row not returning Row Number

I have a scenario that starts as follows:

The iterator has an array of tab names, so the Search Rows function can go through multiple tabs on the sheet and process them accordingly. This part works fine - but only because when I originally set this up, I could access the various column fields (per row) and row numbers from the Search Rows step.

Now, mysteriously, I can’t. I’m trying to Set Variable after the Search Rows step and these are the only fields I have available to me.

Yes, this is the "normal’ Search Rows and not the Advanced one.


What have I done wrong and how can I fix this? Cheers!

Seems weird, Maybe using the sheet as a variable might have messed the mapping option, which shouldn’t be the case though.

Try right-click the module, Run Once and try to execute it once and see if the mapping is available after that?

1 Like

Just tried to Run Once - and nope, no luck! Still can’t see anything but Total numbers of bundles and Bundle order position.

This what the legacy stuff downstream in the same scenario looks like (using properies I can’t see/access anymore - but still working, somehow):

I recorded a short screen-sharing video to explain the resolution.

Watch here: Loom | Free Screen & Video Recording Software | Loom

Let me know should you have any further questions and do not hesitate to reach out to us for help anytime.

1 Like

Hi Manish,

Thanks for taking the time for make a video, but unfortunately it doesn’t solve the issue.

  1. The module was never deleted. You can see in the screenshot below that the reference number (3) of the Search Rows step is the same as what’s being referenced further downstream.

  2. The module is fully configured - every field is set. I’ve tried changing the spreadsheet ID, how it’s set, etc.

  3. I tried unlinking and relinking various parts but it doesn’t help.

Continuing to try and debug this - found a solution.

It appears that mapping a variable (Module 4 in my flow, see below) for Sheet Name is what breaks this. When I mapped the iterator’s (Module 7) value instead, the row number and other fields suddenly became visible downstream.


Mysterious. I see no reason why a variable should cause this problem, but happy to have a workaround.