Googler Translate not maintaining line breaks

Hi there,

I’m using Google Translate module. The issue is that if I use as inpunt a string that has line breaks, after the translation, the resulting string is a one-line. How can I maintain the line breaks in the output?

According to Method: translate  |  Cloud Translation  |  Google Cloud,

You’ll need to set the Format field/parameter to text. The default is html.

Unfortunately the module did not include this field/parameter. I’m sure others would agree that this is a nice feature to have.

You can submit this suggestion to the Idea exchange, under App improvement ideas.

Don’t forget to search for it first, just in case someone already suggested it, so that you don’t end up creating a duplicate.

You should be able to integrate the endpoints in Make using the app’s universal module (Make an API call) or generic HTTP “Make a request” module.

If you need assistance in setting up the app’s universal module, or the generic HTTP module, please provide additional information about what you have tried with regards to the external service’s Developer API Reference – how you are setting the connection up, a link to the endpoint are you trying to connect to, and what errors you are encountering.

You can also complete this brand new course/tutorial in the Make Academy on how to use external APIs — API calls with HTTP modules

  • API and Endpoints
  • Header and body
  • Multipart/form-data
  • OAuth 2.0

Alternatively, you can send the source content as HTML, e.g.:

<p>This is a test</p>
<p>This is another line</p>


samliewrequest private consultation