Log calls from Android to Google Sheets using Make doesn't capture phone number

We have built an scenario with two modules. The trigger is the "Watch completed incoming calls" module (Andoid) and ending is the "Add a Row" module (Google Sheets). Both modules are correctly configured to register calls but in some devices, the "number" field remains empty, while it shoulded have been captured by the make app. We need to know why isnt this field being captured y cómo podría resolverse. Adjunt you will find the log archive from MAKE App and the scenario blue print.

deviceinfo.json (1.8 KB)

blueprint.json (20.1 KB)

Hi! @Cristian_Alvarado , were you able to solve the problem?
I have exactly the same problem :sleepy:

I think it’s likely to be something to do with permissions on the particular phone device. I noted in the deviceinfo.json file that NOTIFICATION_POLICY_ACCESS_GRANTED is false. This permission might be required.

A quick web search result suggests that this might be linked to the Do Not Disturb access settings.


I’m having the same problem with a Pixel 6 Pro.
Any solution?

Hey @DavidGurr_Make any idea how to fix this?

Heya there @eduardo.xyz :wave:

just wanted to step in and offer a piece of friendly advice here. It’s generally more effective to ask your question in a new thread rather than post it under an existing conversation. If you start a new thread you are more likely to get an answer.

This strategy also keeps our community healthy and neat while others look for solutions to similar problems.
Thanks for keeping that in mind :pray:

1 Like