Mapping not from Make directly


I’m going to try to explain this as clearly as possible, but it’s not going to be easy :grinning:.

I have two modules :

I have a first module (Set Variable) like this :

And a second one with a mapping to the first one :

When i run this scenario, the result is ok => 5

Now i want to change the logic. I got 3 modules. I add a “Google Sheets / Get range values” between the two “Set Variables” :

In my spreadsheet i have one information (a mapping instruction) :

An the second “Set variable” module is mapped like this :

I don’t get the information from the first “set variable” module anymore but from the “Google Sheets” module.

But when i run the scenario now :

The result is not ok because the module don"t get the mapping, it takes it like … text.

Do you see the problem ? Any idea or solution please?

Thanks a lot

Welcome to the Make community!

You cannot dynamically use Make field RAW values stored in an external service.

The external service stores it as a string.

You are setting the Variable 2 as a string – whatever is contained in that cell/range. It does not convert the string into a Make field RAW value.

This is not a bug.