OAuth Redirect URI Failures

Continuing the discussion from How do I resolve invalid OAuth2 redirect_uri?:

I’ve tried three Redirect URIs that I’ve found in various documentation locations, and all have failed with the same error.

I’m new to OAuth, but I’m pretty tech savvy and should be able to figure out problems similar to this. Unfortunately, this one has me stumped, and Make support hasn’t been great.

Redirect URI attempts (in order):

Module Error:
Failed to verify connection ‘My Bloomerang connection’. Status Code Error: 400
Failed to verify connection ‘My Bloomerang connection’. Status Code Error: 400

URL in OAuth Pop-up:

Appears to be resolving to: https://www.integromat.com/oauth/cb/app


Technically it should be,


Can you crosscheck the settings of Bloomerang and see if the redirect URI is correctly set over there? I recommend you to create a new application there and set the redirect URI as above and see if works for you.

1 Like

I have to go through their support team, so I’m not sure how easily I can get that information or ask for a new application to be created. Below are my replies for their approval process.

Any progress on this @jdg0928 ?

1 Like

No luck… the redirect URI is currently:


The URI you mentioned was the first one I tried. I heard from Make support, so I’m going to give this one more try.

Most of the times this error are from the app side. Not Make.

The redirect has to be


So I would suggest just go to bloomerang app and just double check. If you find the same redirect URL, You could contact Bloomerang support that you are not able to use the Oauth.


1 Like

I have no visibility into the Bloomerang side, as I’m working through their support team. They provided a list of requirements, which I provided based on information in the Make support documentation.

As for the URI, below is the response from Make support:

The rediurect URI you must use is this: https://www.make.com/oauth/cb/app The others are meant to be used with our HTTP modules only, not with Custom Apps.

So, I’ve asked Bloomerang to try that URI again. If this fails, I’m going to see if Integrately will work instead. I can’t leave Zapier if there’s not a connection to Bloomerang, and support concerns are not giving me confidence for the future. It’s a bummer because I love the Make UX.

Make support acknowledged the URI on the Connection page (in the red box below) may be incorrect.


I was asked to use the URI below instead. My request is with the vendor support team, so I’ll give it a try as soon as they make the update.



Okay, making progress. The redirect works with the most recent URI (see below), which means nearly all of Make’s documentation is incorrect. Sigh.

Now the issue is with granting permission. When I click Grant Access, the following error appears:

“message”: “The request failed due to failure of a previous request.”,
“code”: “SC424”,
“suberrors”: [
“message”: “Status Code Error: 401”,
“name”: “RuntimeError”
“debug”: [
“body”: {
“code”: “",
“client_id”: “e7d9…(removed for forum post)…5091”,
“grant_type”: “authorization_code”,
“redirect_uri”: “https://www.integromat.com/oauth/cb/app”,
“client_secret”: "

“headers”: {
“user-agent”: “Make/production”,
“content-type”: “application/x-www-form-urlencoded”
“timeout”: 40000,
“type”: “urlencoded”
“body”: {
“Message”: “Client credentials are required for this operation”,
“ErrorCode”: 111,
“error”: “invalid_client”,
“error_description”: “Client credentials are required for this operation”
“headers”: {
“date”: “Thu, 11 May 2023 13:51:25 GMT”,
“content-type”: “application/json; charset=utf-8”,
“content-length”: “200”,
“connection”: “close”,
“cache-control”: “no-store, no-cache”,
“pragma”: “no-cache”,
“server”: “Microsoft-IIS/8.5”,
“x-aspnet-version”: “4.0.30319”,
“x-powered-by”: “ASP.NET”,
“access-control-allow-origin”: “*”,
“access-control-allow-headers”: “Content-Type,Authorization”,
“access-control-allow-methods”: “POST,GET,PUT,DELETE,HEAD,OPTIONS”
“Status Code Error: 401”

From what I found in the forums and online with other vendors, this is an issue on Make’s side, not Bloomerang. I’ve updated my support tickets with each vendor, so we’ll see what happens.

@Michaela I’ve noticed you helped with similar issues last fall, so maybe you can advise or look into this on your end. Thanks!

Heya @jdg0928 thanks for reaching out and tagging me!

If you’re developing a custom app, the best way to get help is to raise a ticket and select the “Developer Platform > Custom Apps > Help with Creating of Custom App” options. That way, our QA specialists can give you personalized assistance and help you with any issues or questions you may have.

Thanks! I have an open ticket with them. Figured I’d also go this route since support responses are inconsistent at best. Fingers crossed they get back to me soon.

1 Like

It’s fantastic that you reached out to the community for assistance! That’s a great way to get additional perspectives and insights on any technical issues you might be facing.

That being said, custom apps can be quite complex, and it’s worth noting that QA specialists have the most in-depth knowledge and expertise to help guide you through any challenges. Awesome that you’ve already opened a ticket with them!

By combining the knowledge of the community with the response from QA, you’ll be able to get the most comprehensive and accurate help possible. I’m sure they’ll get back to you soon with the guidance you need.

Feel free to keep us posted on your progress :raised_hands:

Did you end up getting this resolved? I’m trying to connect to a different API in a custom app, but also hitting the same “Status Code Error: 401” error no matter which redirect URI I use.

Not yet. The vendor (Bloomerang) has a copy of the code used in the integration. They are evaluating it and hoping to figure out the root cause. They’ve had it about a week, but I haven’t heard from them yet.

I am coming to clear up the confusion with redirect URIs in custom apps on Make.

There are 2 valid combinations of redirect URIs and their IML variables:

  • oauth.redirectUri variable will return the old redirect URI https://www.integromat.com/oauth/cb/app

  • oauth.makeRedirectUri variable will return the new redirect URI https://www.make.com/oauth/cb/app

If you need to set up an oauth connection, just make sure that you work with the correct combination of redirect URI and its IML variable that you map in the connection’s code.

Both combinations are valid and supported. We don’t plan any deprecation or shutdown of the old redirect URI at the moment.

The redirect URIs and the Oauth2 connection are documented here: OAuth 2.0 - Make Apps

:information_source: Make was formerly called Integromat, which means you can trust the Integromat URL as much as any Make URL. (I am mentioning it here for those users who came after the Integromat’s rebranding, to reduce the confusion)

If you are setting up HTTP > Make an OAuth 2 request module, the redirect URI is: https://www.integromat.com/oauth/cb/oauth2
The setup of a such connection is documented here:
How to connect Make to any web service that uses OAuth2 authorization

Not sure if this is still open, but sharing incase it helps: we recently released a make.com app for Bloomerang: Bloomerang Integration for Make.com | by Synergetic

Yes! I’m the person who has been working with Richard to develop the application. I have to finish testing all the modules, but so far this has been the answer to my problem. It’s very exciting!

1 Like