Odoo create a lead failing

Hello, I have a production instance and a staging instance of odoo 17 on the same server. Staging is a very recent copy of production take just before I started testing this scenario.
My testing on staging worked perfectly.
Now I am trying to set it up on production, I have run into a few issues. The Odoo connector is not pulling in the fields from CRM. Please see the image attached.

Any idea what is going on here??
Thanks in advance

BTW, the user I am connecting to Odoo with has all the necessary permissions to the CRM. In fact, they are administrator! As you can see, it finds this “Ratings” field… The API key is working correctly. From the Odoo logs, I can see the code 200 messages when it hits the server.

Additional, I set up the “list leads” using the same connector and that worked! I have just tested out the “Create a Lead” on a demo instance of Odoo and that worked. Then I went back and all I can see is the “Ratings” field… Not sure where to go from here…
Any help would be greatly appreciated.

The Odoo database for which you created a connection has to have access to Odoo CRM app.

I would suggest you create the Odoo connection with a database that contains the CRM, then you should be able to see the fields in the Odoo “Create a Lead” module.

1 Like

All due respect but of course it has CRM installed. That would be pretty silly if it did not. Considering that “List Leads” works successfully would also indicate that CRM is installed and the user has access. The user account I am connecting with had full privileges on the database.
As mentioned in my posting, I have used the same scenario to “Create a Lead” successfully to other test databases but not the important one - my production database. The connection tests successful to Production. Yet when I try to use it, the only field it shows is Ratings.