Problem with Data Store filter

I have one scenario that creates a Data store using the following parameters
blueprint(3).json (17.5 KB)

it comes out to look like this:

Now, I am having an issue with the data store filters. Here is my current scenario:
blueprint(2).json (25.4 KB)

The scenario runs on a half hourly schedule. The first module looks through a filter of “Follow-up date & time” being between 20 minutes before and after the current time. So for example if it happens at 1:00 AM, the filter should allow any values between 12:40 AM and 1:20 AM.

The issue is, it is not letting them through the filter if its created automatically using a different scenario. If i manually change the date and time in the Data store, it typically works, also when i run it manually. But if i have the other scenario create a data store, and then have this scenario search through the data store, it doesnt work.

Please if someone can help me with this, id be very grateful.

@ea1 are you getting data from your webhook in text? format


@sachinkadam5 I mean yes, but when i input the Fallback Match from the text parser that is only for the addHours part. The “now” part should keep it in a date format, no? Could it be that it is changing the format of the data store? how would that make sense though?

The data store that creates the record does correctly store it as the correct number of hours later, but it is just not being read by the second scenario.

If you run the Data Store module at the start of the scenario on its own does it retrieve the expected data from the data store on its own (assuming there are records that fit the criteria?)


I just tried and it did let it through. But like i said previously, when i manually change the data store, it seems to work. Its only when the record is created automatically that it doesnt detect it

So if you run it manually with the auto created records can you confirm the records that are automatically created are actually in the range? The data is instantly saved so the only explanation is the records created are not in the range in terms of time.


The data is in fact in the range. I have done this before, but ill run it automatically now so i can show you

Ok, now its doing what it did the other night. When i run it now, it is letting it through, however, last time i thought i had figured it out, so i let it run continoulsly, and when i woke up, i realized it stopped working after the first run

wait nevermind, made a mistake, it did now work

Here is the results from the module:

Here is the automated test data:

You can see it did not go through the filter

Have you checked the time zone of the underlying data? And your time zone on your account?


Yes i have, both are set to my current one. And as i said, when i do it manually for the specified time, it works, its only when automatic

hey @ea1 , i have almost same issue with filter, but it is not going though filter when i use dateTime Later - operator , it worked without mistakes yet, but few days ago it started not going though filter

This has to be a bug. I have tried legitimately everything!


yep, absolutely . it should have to be bug

@alex.newpath would you know who i have to contact to figure this out?

Make support can help you out if this is a bug. You can open a ticket under the help icon on the bottom right corner.

Hello @ea1 :wave:

I see that you opened a ticket with us and that the support team investigated this and gave you the following advice. I’m sharing it here for the benefit of the community. :arrow_down:

Make Support response:

Unfortunately, we were not able to reproduce this behavior on our end. We suggest that you please check your local format of the date and time. Working with date and time can be tricky so we would suggest adding the parseDate() and formatDate() functions in your filters as it is showing in your Data store make sure all the formats match and then give it a try.

1 Like