Remove function to remove a value/array from an array in Airtable

I work with MAKE and I have a very strange problem with the remove function to remove a value/array from an array
I receive in MAKE an array of linked fields and I want to return the entire array except for one ID that I received from a separate module in MAKE for some reason it didn’t work
I tried to insert the ID that I want to remove manually into the remove and it did work for me
I checked what the difference is between them and I saw that when I receive it from the second module it is surrounded by square brackets and when I insert it manually it is not surrounded by square brackets (meaning the square brackets make it not work…)

why is this happening to me?

(What’s interesting… that add even if you enter with square brackets and if you enter without square brackets it works)

In this way it worked fine👇
WhatsApp Image 2023-08-22 at 16.42.33

This way it didn’t work👇

Hi @leibi

The removal function is effective only when dealing with simple arrays. In such scenarios, I suggest employing an array iterator, then applying an aggregator and incorporating a filter step to avoid the particular element.

MSquare Support
Visit us here
Youtube Channel



Why is it different from the ADD function?

Hi @leibi

Add function accept array and add values again to the array. But I think your requirement is different from that.


hi @Msquare_Automation

It’s understandable to me.
My question is why does the ADD function work both on data that is received as an array and on data that is received as a single value, and the REMOVE function only works on values that are received as a single value and not on values that are received as an array?

1 Like