Using Twitter and ChatGPT to create new tweets

I am attempting to use ChatGPT to create new content from existing twitter posts.

First I am using the tweet search in the twitter module, to source new tweets

Then I am using ChatGPT module to create a new completion, using some directions to create a new tweet.

Then I am using the Twitter modult to create a new tweet based on the output from ChatGPT

However the first process results in an error with the twitter modult

I get this: " Error

[400] Invalid Request: One or more parameters to your request was invalid."

In the “search tweet” module.

I don’t see other errors.

I am just using two key words for the search function.

Nothing more.

Is there not a template for this?

Verify API credentials: Ensure that you have correctly set up your Twitter API credentials (consumer key, consumer secret, access token, and access token secret) in the Twitter module. Double-check if any of the credentials are missing or incorrect.
Check search query: Make sure that the search query you’re using contains valid keywords or phrases. If the keywords are too generic or not relevant, it might affect the search results or even result in an error. Try using more specific or unique keywords to narrow down the search.
To simplify the troubleshooting process, you can try using the default settings in the “Search Tweets” module without any additional parameters. This will allow you to check if the error persists even with the basic configuration.
Best Regards

1 Like

It looks like your connection for Twitter is not proper.

Need to see the scenario to give better advise.

It tells me that my twitter connection is valid. I don’t see any other problem.

Is there anyone who has made a template for this?

BTW This is my error;

This is so much easier on Zapier;

These are the permissions that Twitter has authorized;


Hey, did you find a solution for this?

I’m getting this same error message for my Twitter integration. I actually have mine deploying 3 posts, the first worked just fine, but on the second attempt I got this same error. I think it’s because we are getting rate-limited. Meaning sending so much to quickly.

On posts 1 I got the INPUT and the OUTPUT, but on Post 2 I only got the INPUT but never recieved the OUTPUT reply from Twitter, hense the error.

I’m currently testing with Automatic Error Handler.