Anyone else stuck in an infinite Google SSO loop?

Tried to login to my Integromat account this morning, only to get stuck in an infinite loop thanks to the transition to Make.

Here’s what happens:

  1. Attempting ‘Login with Google’ on integromat.com
  2. It redirects to the Register page on Make.com
  3. Filling out my details, it say’s ‘We recognise you’
  4. I click Sign In.
  5. It returns me back to the Integromat login screen.
  6. Infinitely repeats.

Anyone else been screwed over by this? Any ideas for a solve?

Hey @hugh, welcome to the community :wave:

Is it maybe possible that you signed up for Integromat using your email and password rather than going through an SSO? If that was the case, it could be causing this loop since there is no SSO associated with your email address in the system.

I have spoken to the Support guys and we have identified the ticket you logged regarding this issue. If what I’ve suggested :arrow_up: is not the case, we’ll further investigate. Either way, one of our agents will get to you soon to help out.

Thanks Michaela. Unfortunately no, I definitely signed up using Google, rather than entering email password.

Interestingly, I was able to access my account from Safari, however I still get stuck in this loop on Chrome.

Thanks for clarifying that, Hugh!

I know this is probably a redundant question but have you tried the good old clearing cache & cookies and opening Integromat in incognito mode?