Can't choose Excel file


I want to write data to an existing Excel file. But I can’t choose that file:

First I can choose the first folder in which the excel file is found:

But after that if I click on the blue + sign, an empty lists opens. This list is empfty after klicking the reload arrows. But many folders exist there.

Is this a bug?


Hello @jantheofel :wave:

Thanks a lot for raising this here in the community! At the moment, it seems we haven’t had other users reporting a similar issue.

I see that since you believe you’ve come across a bug, you opened a ticket with us. That’s a great move since our support team has the necessary tools and permissions to investigate these kinds of issues and potentially escalate them to our dev team.

Let’s see if someone from the community has any input here but please continue the conversation with our support team as they are the ones who can help the best :pray:

1 Like

Hi @jantheofel ,
try to change a method and then do it dynamically and in it pass the ID of the excel file ,

may be that will work for you , thank you

1 Like

I should have mentioned that I tried that way too. But what I couldn’t find was a method to get the workbook ID manually. All the solutions I found (all for other no code tools) basically tell me to create a mini-scenario that just tells me the workbook ID. So I’m going to have the same problem with that.

If you know of another way to get the workbook ID, I’d love to read about it!

Hi @Michaela!

Thanks for your answer. I opened a ticket and share results here.


yes if you open the workbook on your browser you can see the ID in the URL on web , just like sheets , please see

thank you



my URL looks like this:{AB3A7831-CB5F-4703-8F30-4CAD3F22ECD6}&file=FILENAME.xlsx&action=default&mobileredirect=true&DefaultItemOpen=1&ct=1699024916883&wdOrigin=OFFICECOM-WEB.MAIN.EDGEWORTH&cid=e6aa3bef-2452-4234-9111-ec0c56ef772e&wdPreviousSessionSrc=HarmonyWeb&wdPreviousSession=a83b0c4a-cc9f-402e-980d-1c435fa56b50

I tried to find the Workbook ID there but failed.


Hi @jantheofel

it should look like this if you open on browser ,
thank you


You already mentioned this. But I’m not on OneDrive, I’m on sharepoint. Here the URL is different. But maybe this is the issue which I have that this files in in a different environment?

Hi @jantheofel
You mentioned you submitted a ticked already.
If your problem is still not solved.
I can do a zoom meeting with you to sort this out.
Thank you

I’m trying to find confirmation on this, but I read somewhere before that Excel 365 uses the Graph API while Sharepoint uses a completely separate endpoint. The make module uses Graph which may not work with Sharepoint.


Hello there @CodexSolutions thanks a lot for stepping in so readily to lend a hand to the community :pray:

If you do end up jumping on a call to chat about this, could you please circle back to this thread and share your findings with the rest of the users? You see, our community thrives on sharing knowledge publicly, ensuring that it’s accessible for everyone’s benefit.

Thanks a lot :raised_hands:

1 Like