Configuring an IP restriction for webhooks seems to block everything


I am struggling to whitelist an IP address in Make.

:footprints: The steps you have taken

  1. Make does not offer an obvious way to see / log what requests were made to its wehbook module, so I have been using the to determine the originating IP of the webhook I am trying to whitelist.
  2. When I leave the IP whitelisting box blank, I can see in the requesting app that the webhook was successful (200 Accepted)
  3. When I paste in the IP address I want to whitelist (having tried both verbatim and with a CIDR ( and then save the webhook; the subsequent call to the Make webhook fails.

There is an answer from @Bjorn.drivn on log IP addresses in make that mentions toggling on the Get request headers option to see where an IP address is coming from. So I tried:

  1. Blanking out the IP whitelist box completely
  2. Toggling the get request headers option
  3. Making a request

And looking for the cf-connecting-ip in the response headers in the originating app. However, all these show is the following:

There is no CF-connecting-ip field that I can see.

I am keen to try out for this integration, but hesitant to set up a wide-open line with no other form of security when the application is meant to be used for work.

I am new to setting up webhooks (I normally just call them :slight_smile: ) so it might be the case of me making a dummy error. Any help would be really appreciated.

Update on this I have now found the CF-connecting-ip field in the logs. For those who were just as lost as I was, you have to leave the configuration environment and:

  1. Click on webhooks in the sidebar
  2. Click on your newly created webhook
  3. Go to logs

You’ll find the CF-connecting-ip field in there (the IP seems to wobble between the one the other solution previously reported and a new one). It’s not obvious how to extract a CIDR from these logs however.

I tried pasting the two IPs in this CIDR generator but if anyone has a better approach I would love to learn it.

1 Like

Hello @Hess welcome to the community :wave:

Awesome work figuring this out! And thanks a lot for stepping back into the community and sharing your solution with us. This could be super helpful to folks facing similar issues in the future :pray:

Keep up the great work :muscle: