Creating a custom App with Webhook/ instant Trigger

Hi there,

I am new to MAKE and test driving different things. I am setting up/ developing a custom APP for our SAAS product, created my first action modules - so far so good.

I am struggling (404) with shared Webhooks though.


My connection has an uid declared as follows:

	"url": "",
	"headers": {
		"x-mysass-token": "{{parameters.apiToken}}"
	"response": {
		"uid": "{{body.uid}}",
   	    "data": {
           	"token": "{{body.token}}"      
	"log": {
		"sanitize": ["request.headers.x-mysass-token"]

The connection api call returns as follows:

    "token": "mytoken_value_uuid",
    "uid": "my_userid_uuid"

Connection verification works fine, I can execute a simple hello world read module I created.


I am not sure how the connection should be configured, I tried both “body” and “item” in the mapping:

  "uid": "{{body.uid}}",
  "output": "{{body.event}}"

I am calling the shared url address with the following post request:

POST /app/my_shared_url_address HTTP/1.1
Content-Type: application/json
Connection: close
Content-Length: 152

  "uid" : "my_userid_uuid",
  "event" : {
    "praxisId" : "my_userid_uuid",
    "webhookType" : "SOME_ACTION",
    "refId" : "some_action_refId"

If I send a broken JSON I get a 400 / BAD REQUEST, which tells me the URL is found and the 404 is happing later in the process.

instant trigger

My instant trigger has an empty object {} in the communication section, an empty array in the static parameters.

The interface was generated and I guess is of no relevance concerning my problem.


If I try to POST data to the webhook url I get a 404 “not found” response. My app is version 1.0.0 and private, both modules are “visible” and “on”.

I do “re”-verify the connection every time I change anything, no errors here.

The scenario I created has a simple instant trigger pushing the received event data to a slack channel.

I did create an API KEY in my user profile and tried making the POST call with a Bearer Authentication (suggestion of ChatGPT, lol), but it did not help.

I am not sure how to debug it, the error 404 is not really helping.

Any tipps?

Can’t find any information about Webhooks and API-Keys - at least not in the Webhooks documentation.

It seems the app must be published to have shared webhooks listening to calls.

Please update the documentation…

Heya @Papick_G_Taboada welcome to the community :wave:

Thanks a lot for raising this issue here. This is not really how the process normally goes :arrow_down:

Could you please open a ticket and report this?

Thanks a lot :pray: