Data Mapping Not Showing | Iterator Issue

1 - I’m getting data from the API

2 - Using iterator

3 - Updating the data using API

Smartlead API.

Here’s what happening:

1 - I got all the data from API

2 - I got that data into iterator

3 - Now when I want to update the data, it only shows the first part of the data.

For ex: I want all of those numbers (1, 2,3,4,5) But it only gives me (1)

I would appreciate your help guys!

Welcome to the Make community!

days is an array – you can see that by the square brackets after it [ ].

If you want the days as a single string like "1,2,3,4,5", you can use


If you need more assistance, please provide the following:

1. Scenario blueprint

Please export the scenario blueprint file to allow others to view the mappings and settings. At the bottom of the scenario editor, you can click on the three dots to find the Export Blueprint menu item.

(Note: Exporting your scenario will not include private information or keys to your connections)

Uploading it here will look like this:

blueprint.json (12.3 KB)

2. And most importantly, Output bundles

Please provide the output bundles of the modules by running the scenario, then click the white speech bubble on the top-right of each module, save the bundle contents in your text editor as a bundle.json file, and upload it here into this discussion thread.

Providing the output bundles will allow others to replicate what is going on in the scenario even if they do not use the external service.

Following these steps will allow others to assist you here. Thanks!


I have uploaded the blueprint @samliew

blueprint.json (31.4 KB)

@samliew any update on this brother?

Sorry, the blueprint is not enough. The output bundles are more important.