Error Calling Smartsheet Mapped Sheet ID with Update Row Module

I’m working an automation that will update a cell value on one sheet when a cell value on another sheet is updated. I’m making this automation in (Integromat).

Here’s the flow: Trigger is change in column on Sheet 1 - Search everywhere for Client ID of row changed on Sheet 1 (values are unique so it is set to only return 1 result) - Get row: sheet mapped to parent object ID (sheet ID) and row mapped to child object ID (row ID) .

For whatever reason this doesn’t work when I try to call the sheet using the Update Row or Update Row Mappable modules. I get the following error: An unexpected error has occurred. Please contact the Support team at Contact Support | Smartsheet Learning Center for assistance. (error code: 4000, ref ID: mz01ih)

Next I tried building it out a little bit to see if the issue was that i was calling to parent and child objects rather than sheet and row IDs (even though the values are the same). I started with an update trigger - Search everywhere - Get sheet (based on parent object ID) (Worked) - Get row (based on Sheet ID from previous call and Child Object ID from the Search Everywhere call) (worked) - Update row (mapped to Sheet ID from previous call and row ID from previous call) - Still getting the same error.

It only seems to happen when I use Update Row or Update Row Mappable in (Integromat). For other modules calling to the parent object ID or sheet ID doesn’t give me this error. I was able to modify the cell I was trying to change using Update Cell just fine. I really don’t want to have to map this out column by column though.

There are a few possible causes and troubleshooting steps you can try:
Confirm sheet and row IDs: Double-check that you have correctly mapped the sheet and row IDs in the Update Row or Update Row Mappable modules. Ensure that you are using the correct IDs from the previous modules, and that the IDs are being passed as expected.
Verify authentication: Make sure that you have authenticated your Smartsheet account properly in Integromat. If the authentication is not set up correctly, it can result in an error when trying to update the row.
Check column mapping: Ensure that you have correctly mapped the column values in the Update Row or Update Row Mappable modules. Make sure that the column names or IDs are accurately mapped to the new values you want to update.
Test with a different sheet: Create a test scenario with a different sheet to see if the issue persists. This can help determine if the problem is specific to the sheet you are working with or if it is a general issue with the modules. If the error occurs consistently across different sheets.
For Expert Suggestion
Best Regards

1 Like