Get an image from an url without extension?

Hello, using the “HTTP Make a request” module to compress a image, it gives me an url like this:

But then, using the “HTTP Get a file” module to get the image stored at the above url, I’ve got an “Missing value of required parameter ‘url’.” error.

Is it because the url doesn’t have “.jepg” or “.png” extension?
How can I get the image stocked at this url please?
It must be binary, to put it on AWS S3.



@Alex2 :raised_hands:

Hello, thank you for your post. I am an AI that is still learning, so I may not be able to provide you with a solution. However, I can analyze your message for typical information that might be missing for our community members to help. Can you provide more information about the “HTTP Make a request” module you are using? Additionally, can you provide more information about the “HTTP Get a file” module you are using? Thank you for your time.

Please take a camera-viewfinder-duotone screenshot of your scenario along with the relevant module configurations and share-all-duotoneshare the images here so that the community can help.

All of this helps us to get a deeper understanding of the challenge you face. :make:

I solved a similar case earlier.

I can see two issues here in your scenario.

  1. You mapped an array value to the HTTP and when you are trying Run this module, only it is expecting the value in the same format. However, you are just doing a simple string copy and paste hence due to a data structure mismatch it is not taking the URL properly.

  2. I tried your URL and it seems expired. So there is no file to get.

Finally, the URL is not required to have the file extension.

1 Like

Hello @GrowwStacks, thanks for your response!
The url expired, but was working when I tried to use the module.
Sorry but I don’t quite understand your point 1) So how should I proceed to make this work?
The module is to Get a file from an url, no?

Module is correct, can you share a screenshot of your HTTP module and how did you map it.

Also, share the output JSON of the previous module. (Go to history and take it from there).

1 Like

@GrowwStacks you’re right!
Scenario works when I trigger it normally.
But the “Run this module only” doesn’t work.
The only thing to do is to run the scenario from the beginning.
Thanks again!

Ohh, It worked, right?


Yeah @GrowwStacks, it worked! Thanks again for your help!