GET FULL Output bundle of webhook

This is driving me nuts, I cannot believe there is no easy way to do this basic thing.

All I want to do is to simply load the entire output of the webhook as a string into a cell, but I can only do that with collections inside the main JSON body, but NOT THE JSON BODY ITSELF, WHY?

My webhook outputs this bundle and i want to access the bundle itself, but I cannot drag or reference it. If I type {{1. }} it won’t work, I tried {{1. Bundle 1}} still nothing. Also tried {{1. Output}} nope.

All I want is a long string with the output of the webhook which exists below.

But when I have to reference output data from the webhook I CANNOT reference the BUNDLE, I can only reference collections from within the bundle, which is not what I want.

I tried using a “transform to JSON” but there also I cannot reference the entire bundle, only collections from it and anyway what’s the point in transforming … JSON TO JSON, a waste of operations when the webhook already outputs a string as a bundle.

Hi @Laurentiu_Andrei ,

I understand that you would like to use the data as a JSON string for easy mapping to another field. To achieve this, you can follow these steps to activate the necessary setting in your webhook:

  1. Open your webhook and click the EDIT button
  2. Enable the “Show advanced settings” toggle
  3. Activate the option “JSON pass-through”

By following these steps, your webhook will output a variable with the JSON data represented as a string value, which you can then easily use for mapping purposes:

Glenn - Callinetic


Thanks, that worked and I can achieve what I wanted.

Now the tradeoff is that I can’t have the bits like before, seems to be either or, but not both “features” at the same time as that is a boolean.

If you would like to work with the JSON in your scenario, you can pass the JSON string to a ‘Parse JSON’ module. This will output the variables like you had them before.

Glenn - Callinetic


I have set the JSON pass thru to true, but I am still getting the output bundle without a vlaue handle. So I can’t use the json input

Stoopid user error. I was not sending content-type: app/json