GMail Label unable to attach to new draft [Potential Bug]

Hey Make Community!

I’m working on a side project and within my automation I need to attach a label to a draft in order to kick off another automation for verification. (It has to be done this way in order to preserve the Gmail Thread)

This is the output from the creation of the Draft, note the Message ID Structure.

However This is the error code followed by the next module

I dug around in the DOM portion of GMail, I found that there’s some IDs and legacy IDs, but nothing in the same syntax of the module.

I got curious and took the data-legacy-thread-id and ran the module stand-alone

And would you look at that! It runs just fine!

I wasn’t able to get this to work on any non-legacy code and didn’t dive through each legacy data id to see which ones worked.

The specific module in question would be Gmail/Create a draft, and the output relating to the Message ID.

Hi @BordenC ,

What is the result if you use the ID before the @engine…?

Glenn - Callinetic

1 Like

Hey @Callinetic,
I had that same thought when debugging and it resulted in issue, I even went as far as stripping the hyphens and “<” out with the same result. I didn’t document that finding, so thank you for your suggestion!

Sadly the only way I was able to get the scenario to work was hard coding the legacy-id, which isn’t an option for the automation.

I opened a ticket with support for this, it’s definitely at the module level when a new Gmail Draft is made. Hoping I don’t have to change gears and redo the automation in Python :X

Hi, would love to know if are there any news on this issue? I am facing the exact same problem (with minor differences - using a mailhook and trying to either place a label or mark an email as read).

Sadly, no. It’s been brought up to the development team