Google Ads Apps not Loading in Scenario Builder

I’m trying to add a Google Ads Campaign Manager, and I’m seeing that all 4 Google Ads apps are not able to be added to Scenarios. Each one, once clicked, simply doesn’t do anything.

Video here: Loom | Free Screen & Video Recording Software | Loom

Might be related to the issues mentioned in this thread, but seems to be a UI issue on the Make side. I tested this in both Make and Integromat and both builders are broken.

Can the support team investigate and let me know a solution?


Nevermind, this was because I had Ad Blocker on :man_facepalming:

1 Like

For anyone who runs into this issue - if you have an in-browser ad blocker (or likely any other form of DNS based URL blocking with an Ad blacklist) the integrations AND even the marketing page for the Make google ads integration will not load.

Go ahead and whitelist the site if you need to display the site and whitelist the specific make instance you are on (us1, etc…) and that will solve the issue.

Jordan and I ran into this with uBlock Origin and Adblock Plus in Chrome.

Hey, what happened when you found out it was from your ad blocker ? Did you disabled it ? On what url ? I did that on both and, and it still doesn’t work…