Google Cloud Text-to-Speech Fails to authorize a connection

I’ve been trying to get Google Cloud Text-to-Speech set up for a couple of hours now but to no avail. I keep running into an error when atempting to verify my account in the Google Oauth screen. I receive the following error:

"Error 400: redirect URI mismatch

You can’t sign in to this app because it doesn’t comply with
Google’s Auth 2.0 policy."

I noticed that the redirect URI is coming back from Google as

I had seen somewhere that it should be set using, which also throws an error when I specify that in cloud console. I’ve tried including one, then the other, then both.

My account is valid, and there is a form of payment connected. (both suggested sources of possible issues)

Not sure what else to do, or if the issue lies in the make module its self. Any suggestions would be greatly appreciated.

CleanShot 2023-01-03 at 10.34.42

Hi. Are you using a gmail account or a Google Workspace account?

If you need additional support, please don’t hesitate to reach out.


Thanks for the response. I’m using Google Workspace Individual (which I believe behaves more like Gmail than a true Google Workspace account (i.e. with your own domain).

Hi @cryophobic,

I see the answer is already in your post.
The redirect URL should be
What I can see from your screenshot is that you stripped out oauth from the URL.

I tested myself with and it worked. So I assume it will also fix your problem. (Don’t forget to hit the save button :slight_smile: )

Glenn - Callinetic

1 Like

:man_facepalming: Really appreciate the help there. I have no clue how that got lost, but great catch. Just tried it out and it works as expected. I hadn’t even noticed the discrepancy. I guess I was too focused on it being something more complicated.

1 Like