Google Drive appends .txt to my *.md file

I take notes on a Kindle Scribe and want to automate adding them to my Google drive.

When you send your note file from the Scribe to Amazon, Amazon sends a message reporting that you’ve send them a file and they allow you to download two version of the document: a PDF and an OCR’d TXT file.

My script works mostly. I forward the message from Amazon to a webhook email. My script then retrieves the two separate files and saves them to folders on my Google Drive.

  • The PDF save works fine, probably because GD realizes I’m sending a PDF.

  • But the text file does not. My goal is to save the document to my Obsidian folder, so I want the file to have an .md (markdown) extension. But what I’m getting is this:

In the Google Drive “upload a file” module, I’ve specified the new filename:

The lightbulb text below the file name notes that I don’t need to include the extension, but I want to include the extension because I want the file to be saved with the .md extension.

This might be a Google drive issue that can’t fix but if there is a way to prevent the .txt from being appended to my filename, that would be great.


Remove the .md from your “New File Name” field (which does not allow file extension – see the description below)

For the file field, split it into the “Map” option, and there you can insert the file name with extension of choice.


That works perfectly. Many thanks!