Google my Business integration error: Access blocked: has not completed the Google verification process

I’m trying to set an integration with my Google My Business profile. I created a project and had it approved by google, then kept following the guide but it seemed outdated. I had to choose the user type so I chose external. I had a problem setting Authorized redirect URIs as it caused an error, so I copied all the urls I found of the forum:

My authorized domains are set as and When I attemt a connect, I get an error: has not completed the Google verification process. The app is currently being tested and can only be accessed by developer-approved testers. If you think you should have access, contact the developer.

If you are a developer of, see error details.

Error 403: access_denied

When I remove from authorized domains and remove the urls with integromat it them, I get another error 400:redirect_uri_mismatch.

I searched the forum looking for the right urls, but didn’t find a solution that worked for me. I will greatly appreciate any help

You should have no authorised domains set in your custom GCP app.

You only need to enable the API, set the right scopes, and set the correct redirect URIs.

For further assistance, please provide screenshots of the entire setup process.

samliewrequest private consultation

Join the unofficial Make Discord server to chat with us!


Hi, when I set the redirect URL the autorized domains get copied from there, and I can’t remove them,

Can you please tell me also whetver my redirect URIs are correct? I greatly appreciate your help!

did you find the answer? I have the same problem!

Unfortunatelly not. We got tired of the documentation not being updated and considering switching to zapier - there I can connect Google my Business with just one click, loging to the google account. It’s a pity make doesn’t offer such an easy solution

Hi @Gogler_Sp_z_o_o, have you checked all steps, including the “Production” step provided by @samliew here: ?

For the Google Business App, you only need the following redirect urls:

Can you give it a try and check if you have followed this step (I took the image from the post of @samliew):