Google Sheets Search Rows is Rounding the search value

My goal is to search the submission id in column A, this is only the 3rd action in the scenario and it is causing problems because it is rounding the search value. IDK why i tried changing the search data types to text. I also tried setting the data type in sheets. I tried changing equals to contains in an attempt to fix it still same results. Any idea would be appreciated, this used to work and now just stopped. I tried re creating the action new in make and i have the same problem.




image

It apears that make is doing this? Im not sure, but when it asks for a value i give it 5886796106012705011, but the bundle content for input shows the rounded number. I just tried toString() and ascii()functions no change. I also tried the advanced options selecting unformatted, still no change.

Advanced Search does the same thing, while in there i pressed down after pasting in my search value and it appears to think my id number is a decimal? how do i prevent this?
image

This is similar to:

To avoid the auto-conversion of strings to numbers, try adding an emptystring variable in front of the number.

samliewrequest private consultation

Join the unofficial Make Discord server to chat with us!

3 Likes

i just tried this it does not same issue. toString also doesnt work
image

There must be some workaround to force make to keep it as a string.

The solutions in the previous threads doesn’t apply to you, because they could specify the variable type in a data structure, while your problem is directly using the variable in a filter field.

What about using the built-in function split to split the id by emptystring, and then join by emptystring?

What about using a Text operator: Match pattern with the following:

/^{{ 1.formId }}$/
2 Likes

This is a bug on JotForms, they added a digit to their submission IDs that is past the allowed number of digits on make. I cant treat the number as string becuase the data comes from jot forms as a number. Jotforms has a widget to allow unique numbers and a allows for a starting point to be defined. its not ideal and will require a few changes but it should allow me to put a unique id on the submisions.

3 Likes

For bugs like this, directly contacting support can often lead to a faster resolution. They have access to your specific account details, scenario and scenario logs, server-side logs, and internal tools and resources, which allows them to investigate more thoroughly than what you have access to. Additionally, sharing sensitive information about your situation might not be suitable for an open forum discussion.

You can open a new ticket, or if you are unable to login for some reason, you also can reach support using the contact form on the website.

If you manage to get your issue resolved with support, we’d still love to hear about it! Sharing your solution on the forum can help others facing similar problems.

Hey there @Lloyd_Johnson :wave:

Thank you very much for this information! :pray:

1 Like