HELP! Mapping Panel fields missing


I’m having issues with the mapping panel. My scenario starts with a webhook which draws in the submission from a form which I’m supposed to use to run a HTTP request but when I try to click on the fields of the form in the mapping panel only the last field shows.

So e.g I have three fields in my form but when I try to map them i can only see the last field. I have tried everything possible and nothing seems to be working. Please help.

Hi @Tammy
I’d appreciate a screenshot showing the mapping screen and what data you receive. I think you are talking about array items, for that here is the formula to get nested object:

Copy here: {{get(map(1.EMAIL; "VALUE"; "ID"; 1); 1)}}

You need to edit this formula as your requirements

1 Like

Here’s the screenshot. There’s supposed to be an array of 3 collections under the field but instead it shows just one.

webhook shot

This is called an array, you can know its an array if you see [] after the key. It will only show the first item from that.

If you want to pick the second item you can just click on the value (even if its showing the first item) then write 2 in it, like this

If its dynamic like it can sometime be second sometimes 3rd item, then you have to use this formula

{{get(map(1.EMAIL; "VALUE"; "ID"; 1); 1)}}
1 Like

Thank you very much.


turns out this isn’t working in the webhooks response module. Is there another way to map fields in an array?

@Tammy You can use the “JSON” → Create JSON module to create an object with all required items. Make sure you set the data type correctly.
Then in the webhook response module use the output of the JSON.

Hope this helps you. If not, please share some specific about the issue you are having.

I’m unable to map fields in the webhook response module. When I run the scenario, it doesn’t work and the fields come up blank

Thank you for your response. I tried that it didn’t work. Here’s the issue:

  • The fields that I map in the webhook response module turn up blank when the scenario runs. For example if a sentence is supposed to say Your order is {mapped amount field}. It will turn up as Your order is. The mapped field doesn’t show.

  • I tried to map fields that weren’t even in an array and it was the same issue.

@Tammy In that case your mapping function most likely is not setup correctly.
If you send some screenshots with details we will be able to help you :wink:

Alright, what exactly am i sending screenshots of?
And how do i go about resetting my mapping function?

If you send a screenshot from:

  • The data you are trying to map
  • The actualy function you are using for mapping

it would help us understand what kind of data you would like to retrieve, and how you are currently doing this.

Alright, give me some minutes to do that

This is the data I’m trying to map, particularly the data in the fields array.

And this is the function being used