Help Needed with Google Sheets Data Mapping

Hi everyone,

I’m currently using the free version of Make to automate data entry into a Google Sheets document, but I’m running into some issues with data mapping. Here’s what I’ve done so far and the problem I’m facing:

What I’m Trying to Achieve:

I want to automate the process of adding rows to a Google Sheets document with specific data fields from another source.

Setup Details:

  • Scenario: Created a new scenario in
  • Modules: Using the “Google Sheets” module with the “Add a Row” action.
  • Google Sheet: My Google Sheets document has the following headers in the first row: Image, Image Alt Text, Featured, Title, Summary, Category, Creator, Link, Slug, Date.

The Issue:

When I run the scenario, the data does not match the Google Sheets columns correctly. Here’s the output I’m seeing:

What I’ve Tried:

  1. Verified that the Google Sheet has the correct headers.
  2. Ran tests with sample data.

Possible Limitations:

I’m aware that the free version has some limitations, such as the number of modules per scenario and the number of operations per month. Could this be affecting my setup?


  1. Are there specific limitations in the free version that I should be aware of that might be causing this issue?
  2. Any tips or best practices for setting up data mapping in with Google Sheets?

Thank you in advance for your help!

Hello @thecsiz and welcome to the Make Community!

If you want to add a Row to a GSheet, you should add a Google Sheet module called Add a Row. Is this already a step in your scenario?

1 Like

Yes, adding a row to a Google Sheet is already a step in my scenario. The issue I keep running into is that the headers from my Google Sheets document don’t seem to be accessible in, so I’m unable to target the specific columns I want to update via my scenario.

I’ve ensured that the headers are correctly placed in the first row of my Google Sheet, and I’ve successfully connected the sheet in However, when I try to map the data fields, the columns from my Google Sheet don’t appear in the module configuration. This results in data being misaligned or not entered at all.

Ah, I see.

How did you select your spreadsheet in the Add a Row module?

Was it “Select from all”, “Select by Path”, or “Enter Manually”?

For Enter Manually, you won’t see headers, you’ll just need to know ahead of time what columns are where.


That seems to solve my issue.