How to fix Google Sheets that is showing no data works a couple of times and then shows no data

I have tried Google Sheets and Excel and have the same issue. I run the module, and it will show the data. Run it a few more times, and it shows 0 data. It’s the first module, and then it goes to openai.

  • Data size: 0
    Operation 1

I deleted and installed the module, cleared the cache, and closed it. I have searched everything, but nothing works.
I need some suggestions.
Thanks for your help.

Welcome to the Make community!

This is because the module is a POLLING trigger, and not an INSTANT (Webhook) trigger.

There are two main types of triggers, Polling (scheduled), and Instant (webhooks). Polling triggers can only run on a schedule. Instant triggers can be run as soon as data is received by the webhook.

Polling means Make checks external service for changes (pull changes to Make).
Webhook (instant) triggers means external service calls Make when there are new changes (push changes to Make).

The module you are using does not push changes — it’s basically a API request that Make has to occasionally “call” to fetch the latest changes/items.

When there are no changes between the last scheduled and the current run, there is no output. This is called a “check run”, which still uses one operation.

To find out more on the different types of Trigger modules, see refer to Types of Modules and Webhooks sections of the Make help center.

I recommend doing the Make Academy as this is covered.

Here are some useful links and guides you can use to learn more on how to use the Make platform, apps, and app modules. I found these useful when I was learning Make, and hope they might benefit you too —


Help Center Basics

Articles & Videos

samliewrequest private consultation

Join the Make Fans Discord server to chat with other makers!