HTTP - Make A Request takes 2+ mins to send request to MAKE webhook

I’m using the HTTP - Make A Request module to instantly trigger another scenario using a webhook. It has worked fine in the past, but each request is taking over 2 mins to send. This has created a significant bottleneck in the project. I am sending to a webhook so I can pass parameters to the next scenario.

Initially I was sending the parameters in the URL. I thought this could be the reason, but I tested sending the data in JSON and I’m getting the same issue.

Let me know if you have any ideas behind what could be causing this or ways I could trouble shoot. Any help is appreciated!

I solved my problem.

If anyone else is experiencing this issue. My problem was that I had a webhook response module on a route that wasn’t enabled in the scenario where I was sending the request. The Make a Request module must have been expecting a response and was keeping the connection open until it timed out.


Heya @JrJr :wave:

Fantastic that you managed to figure this out and that you decided to let the community what did the trick for you :star_struck: Thanks a lot for keeping us posted, we really appreciate that!

(I’m gonna go ahead and mark your reply as a solution so that we keep the community organized :white_check_mark: )

1 Like