I can't 'see' a module

I have a scenario which receives information from a webhook. I need to parse the JSON received before passing it through to create a Slack message.

However, one of the modules (module 30 in the image) is not visible to other modules, even though it processes data correctly when the scenario runs.

Am I doing something wrong?

This seems like a complex scenario you’re trying to make, perhaps exporting the blueprint might help others investigate further and answer your question.

At the bottom of the scenario editor, you can click on the three dots to find the Export Blueprint menu item.


Uploading it here will look like this:

blueprint.json (119.3 KB)


Sure! Here you go:

blueprint.json (214.4 KB)

This was solved by Oluhosola from Make support. They pointed out that the JSON parser wasn’t finding a data structure. So they copied an output bundle from a test run, pasted that into the module’s input box and ran only that module. Then reverted to the previous settings. And now it works perfectly!


Hey there @Mike_Randall :wave:
Thanks a lot for keeping the community in mind and coming back here with additional information and solutions from our support team. We greatly appreciate it :pray:

Fantastic job and keep it up!