Mailhook And SmartSuite search module, cant use the data of maulhook body

Hello Guys,

I send data from SmartSuite to Make using mail hook, those data are Automation Prefix (which I need to use as a filter), and in the mail hook body I send SmartSuite record ID to get the record and then send this data to Airtbale, the issue is that data that goes to mail hook body can’t be used nor for the filter nor the search data in SmartSuite Screenshot by Lightshot, only data I can use is Subject Screenshot by Lightshot line if I use the subject as a filtering option it’s working but then I cant use body text as a search data, I tried to send both prefix and record id in the subject line and using regex Screenshot by Lightshot Screenshot by Lightshot to split data and then use them but in this case, data cant be used for the filter and for the search too, strange maybe someone has a similar case and come up with the solution.
thanks in advance.

update on this, i tried to use HTTP request and used mailhook text as a mappbale answer and it fails anyway, so it means that Make.com cant recognize data in mailhook text section.

So in conclusion I need to change the text data from mailhook to something that I can use then in other modules, if anyone has idea what I can do please share.

I would appreciate it if you can upload the images here.

1 Like


here you can see the i receive subject line and text, data in subject line can be used and data in Text cant

I tried SmartSuite get record module and when I mapp filed Text from mailhook it gives an error, than I tried to use HTTP module and mapped same text data and received an error
I tried to use pabbly connect and in pabbly its working, some thing happens in make, it doesn’t likes the data in Text field for some reason