Making a Bluesky app: using "$type" in a JSON in a collection

So I managed to make my personal Bluesky app into Make using app creation, I tried making a simple Bluesky post, that did worked. Now I’m trying to upload and post MEDIA into Bluesky. Now I have managed to upload the media using the HTTP module, now to post it, i thought I consolidate the JSON scheme into a collection mappable parameter. Shown on ATProtocol blog

  "$type": "",
  "text": "example post with multiple images attached",
  "createdAt": "2023-08-07T05:49:35.422015Z",
  "embed": {
    "$type": "app.bsky.embed.images",
    "images": [
        "alt": "brief alt text description of the first image",
        "image": {
          "$type": "blob",
          "ref": {
            "$link": "bafkreibabalobzn6cd366ukcsjycp4yymjymgfxcv6xczmlgpemzkz3cfa"
          "mimeType": "image/webp",
          "size": 760898

Now I did try to run it and I got a error thst says Collection can't be converted to text for parameter '$type'. Is it possible that collections don’t support having dollar signs in parameters?

It does look like this in mappable parameters

"name": "$type",
"type": "text"
"label": "Type"

Is there such a workaround on this?

Hello mikey,

If you are mapping the parameters communication this way:


you can use backticks to solve the problem with $: