Missing value of required parameter 'title' and 'content' from Google Sheets to Wordpress


I am trying to add posts to wordpress from Google Sheets. Others I know it works for perfectly.

However, I get this Integration Google Sheets _...

The sheet has new content added every 10 minutes or so and there are 10 posts ready to go?

Thanks in advance and anything else you need let me know

Hi @PBrian,

Can you share what the output is in the Gsheet from the execution history? It seems like you are either getting empty data or there is an issue with mapping you are doing on Wordpress module.

1 Like

Thanks for the reply

It’s text.

I can’t share the actual sheet but it’s not empty

Shared with Zight

Anything else needed to help?

Screenshot from 2023-06-18 21-22-04

Can you click the 1 in the history and share what you are getting there?

1 Like

Shared with Zight

Does this help?

Thanks again for the help really appreciate it

The headers in your Sheet are in row 2, but I think you’ve specified the first row. As a result, the objects from the Title and Full Post columns aren’t available. You need to map these in the Wordpress Create a Post module.

Make sure that your Google Sheets Watch New Rows module has Table contains headers set to Yes and Row with headers set to A2:Z2.

You should then see these values in the output from the Sheets module (along with whatever you have in columns A and b):

  • Keyword (C)
  • Title (D)
  • Full Post (E)
1 Like

yes u were right about the headers thank you.

I do not know how to map the columns in the create a post module…

well I thought i did but obviously not lol

If you haven’t already, I would strongly recommend taking the free Make Academy Foundation course. This covers the basics of mapping (and other important concepts).

1 Like

yes, ive done that and looks good to me
Integration Google Sheets _... - unless ive missed something obvious?

Looks good. Are you still getting an error or is that now working?

nope still getting error

Could you give screenshots of the Error screen, as well as the Sheets module output (as previously)?

1 Like

Shared with Zight
Shared with Zight

I’ve tried clearing cache etc.

Is it because the sheet fields are populated now - so not new? Although it should still pick up the data being present?

Hi @PBrian,

Try this,

  1. Right Click the Watch Rows Module > Choose Where to Start
  2. Set Since specific ID to one of the newly added rows

And< Run the scenario and see if you are getting the data.

1 Like

yay, that worked.

does it remember where it got to i.e. doesnt keep starting at that position and duplicating? If so how do I stop that happening please

Yeah, to do that, You can set the index to the last one, or if you want to rerun then you can set from the row that you want to start it with.

Make, Keeps track of the processed Row ID, so, if you don’t reset it manually then it should theoretically pickup the subsequent Rows.

1 Like

It looks like there’s two rows (row ids 155 and 156) that only have something in columns A and B.

If any new rows get entered into the sheet that don’t have Title and Full Post columns populated, you will get this error again.

If that’s likely, you might want to add a filter on the path from Sheets to Wordpress so that it only proceeds if Title and Full Post are populated.

1 Like

there’s 50 titles and 50 content

ah great, the limit is also the number of posts it does

I’m facing the same error but the scenario runs only the new data but if I run with the old data it doesn’t detect the values and sends the “missing value of Required parameter” I’ve modified where the scenario starts running but only detects data if is new data. Also if I test using a setted parameter name “test name” not using data and still sending the error. Could you please help me? Or do I need to create a new ticket?