OneDrive with multiple Microsoft accounts

Hello, I am new to and have set up some scenarios quite successfully and used them with open AI and Dropbox and Google Drive

The one I’m having trouble with is OneDrive: when I try to make any “watch files” set up, I’m not sure which account it is getting it from for the webhook.

It seems to automatically authenticate but not let me see which of my two Microsoft accounts it has authenticated.

For Excel, I had managed to connect two accounts, but it doesn’t seem to give me any option to generate a Web hook for a second account.

Has anyone tried to do this? — it’s a work and personal Microsoft login. The credentials have worked fine for Excel, Word etc. I also tried to delete those connections to restart, but no luck.

1 Like

Welcome to the Make community!

You can rename connections before you hit Save, or by going to the Connections section of your organization.


samliewrequest private consultation

Join the Make Fans Discord server to chat with other makers!


Thanks for the welcome! Sorry I should have mentioned that I did label them when trying to figure it out. It wasn’t helping.

What seems to have helped so far is:

  1. Sign into Edge using personal account and log into Make to set up my connection in excel using my personal account credentials

  2. Switch browser account to work, do the same as above except now for work account.

What has also helped is that when you try to create the Microsoft connection then the pop-up window seems to authenticate based on the account you logged into. Hence it’s important to be aware of the account. It may be a browser issue as this was not an option on Safari and I wonder if Chrome (logged in with gmail) will act differently.

I am quite sure that earlier it was giving me the option to choose accounts but that doesn’t seem to be happening anymore, so this is the only workaround that works for me.

Now I need to see if this holds for the other things like OneDrive…


Glad to hear that it’s all worked out now.

At least you’ve only got to do this correctly once :slight_smile: