Printify Product Creation Images Not Showing in Mock Ups


I am extremely new to Make, Printify and using AI in general. Still learning a LOT.

I am playing around with automating the upload of products to Printify, however when I use the “Create a Product” module the images are not appearing in the mock up images - it is all just showing as blank. When I edit a product that was created with this module and add the photo manually, once I hit the save button the page just seems to sit there spinning and never actually saves the added photo.

I’m using Chrome, I’ve tried clearing all cookies, enabling third party cookies, logging out and back in to everything. I’ve tried deleting the whole module and re-creating it. I can’t seem to figure out what is causing this issue.

Does anyone have any suggestions or ideas?

Thanks in advance.

Hey, LMMK!

Did you find a solution? I have the very same problem! So frustrating! I can see the listings under ‘My Products’, but the listing mock-ups are all blank… I’d be grateful for any solution you might have worked out yourself (or found elsewhere if no one has provided it here)…

Was there ever an answer here? It is driving me crazy!