Quickbooks invoice discount no longer being applied, but no errors?


The problem:
I am trying to generate a Quickbooks invoice with a 10% discount applied to the total, when an order for a coupon is placed in Acuity Scheduling.

I cannot seem to get the discount to apply using either the Create Invoice or Update Invoice Quickbooks endpoints, no matter what I do. There is no error returned, the run succeeds, and the invoice is generated with every other field correctly populated, but the Discount field when I open the invoice in Quickbooks is always blank.

What I have tried:
In Advanced Settings for the Create Invoice endpoint, under Discount, I have set “Type” to Percent, and “Discount Percent” to 10.

I have also tried using the Create Invoice endpoint to create an invoice without a discount applied, then using the Update Invoice endpoint to retroactively apply the discount to the existing invoice.

In both cases the run succeeds, but when looking at the generated invoice in Quickbooks, there is no discount applied.

Here are my inputs and outputs from the Create Invoice endpoint. The product in this case is priced at £50; I’m not sure if the discount should be showing in the total for output or not (but either way it isn’t applying to the final generated invoice).

Similar problem reported to Quickbooks by another Make user:
To further complicate matters, I am fairly sure this was working when I initially set up the integration a few weeks ago, and that this has only started since taking a break and coming back to the scenario.

I found this question on the Quickbooks developer support page, also from a Make user, who describes an identical problem beginning December 14th 2023 on a long-standing integration. Quickbooks support say they cannot replicate the issue using an API call, which makes me wonder if this is a Make-specific issue.

Has something changed in how Make communicates with the Quickbooks API as of the last few weeks, or am I missing something?

I’m having the same issue as posted above. My automation is not adding the discount to my invoices and there are also no errors.

This scenario was working previously without any issues.

1 Like

Hello @brighter @nina22 :wave:

Thank you very much for bringing this up here in the community :pray:

I just wanted to inform you that this is a known issue on our end and that it was escalated to our development team a couple of hours ago. They are currently investigating this and as soon as we have any updates, I’ll make sure to share them here.

If you’d prefer to receive updates directly in your inbox, feel free to open a ticket with us, and the support team will ensure automated updates are sent your way as soon as they become available.

I’m sorry for any frustration and inconvenience this is causing. Thank you very much for your patience and understanding. :pray:


Do you have any updates here?

Hello @Roman_Sydorak welcome to the community and thanks for bumping this.

Our dev team identified the root cause of the issue and is currently testing a fix before rolling it out to production. There’s no specific ETA to share but the team is actively working to release the fix as promptly as possible.

Once again, I apologize for the trouble and inconvenience this may have caused.
Thank you very much for your patience and understanding throughout this process. :pray:


Hello everyone @here

I just wanted to let you know that the fix has been rolled out and all should be up and running now.
Feel free to test this on your end and let us know if everything is working for you.

Once again, I am very sorry for any trouble this may have caused you.
Thank you very much for your patience and understanding :pray: