Split function not working

Hello,

When I try to run this module only with the same input text it works. But when I run the all scenario it doesn’t work. The data has pipe characters and I would like to split by pipe “|”
Do you have any idea?

I think you are using | (pipe symbol) instead of / (forward slash). URLs generally have /.

Output

Hi @Growwstacks.com
Thanks for your response but I’ve pipe characters in my data and it’s working once I try to run manually just this module only. Not working in full scenario run, this is the issue.

The only reason would be empty input in this module, the previous module would not be giving any output for this mapping

Check output of the immediate previous module for the data field

I can see the input when I checked the history. Maybe it’s a known bug on Make?

I’ve solved the issue by using Compose string module before set variable.

1 Like

Hi there @Mehmet_Demir :wave:

I just wanted to say a quick congrats on solving this one! :muscle:

Also, thanks a lot for remembering to share what you learned with us and for marking your last comment as a solution. Thanks to that, folks searching for similar info in the future will know where to look and the community will stay neat and tidy.

Keep up the great work! :clap:

1 Like