Strange behavior of the Webflow nodes

I want to add an image to an existing item (BlogPost).
If I want to do this via the Webflow node “Update an Item”, this only works if I select the page name and the item manually.

You then have to change the name again (why?!) and I can then add an image there.

If I go the way via the IDs and manually select a Key=Value pair, I get the error “400] Validation Error ‘url’: Field not described in schema: undefined”.

This is strange. I can’t figure it out from the Webflow documentation. I have also tried an HTTP request. Doesn’t work either.
Any Ideas?

Hello @WDGrimm,

In your first screenshot, when you selected ITEM, it’s a dropdown because it’s showing you a list of Items from the Collection that was selected.
Toggle on the Map option to enter in your own Item.
You’ll either need the title or an internal ID of that item.
When you toggle it on the field data may change.
I’m almost certain it’s going to change to that item’s internal ID. You can specify any ID here.

As for the Name field, you can just try using the same existing name of the item. If you’re selecting the item to update dynamically (by switching the Map option to on), then you will likely already have references to both the Webflow Item ID and Name, so you can use the name in that Name field.

I don’t know Webflow that well so I may be way off, so hopefully someone more familiar with Webflow sees this and can chime in.

Hope this helps!


thank you for your thoughts. i have tried almost everything. of course, in the first screenshot i can still select the data and then it works. but i need this functionality dynamically, which is why i rather need a solution for the 2nd screenshot. yes. i also tried to enter the “correct” name of the field under “key” - unfortunately without success. thanks anyway. mostly it’s small things…:wink: