Support for OpenAI Assistant API v2 (file upload + vector stores)

I’m trying to upload a txt file from Google Drive to OpenAI assistants. This used to work but now the assistants can’t read the file.

OpenAI changed to Assistants API v2 by force a few days ago. I’m afraid this is the reason. The files seem to upload successfully, but they are not readable since they are not attached to any vector store and assistants are forced to use the vector stores (it seems).

Changing the assistant to v1 in OpenAI dashboard doesn’t help.

Ideas? Help? Info about v2 compatibility? I need to get the contents of the txt file for AI use.

1 Like

Welcome to the Make community!

Looks like my Telegram AI bot powered by OpenAI Vision and GPT-4-turbo is still working, I didn’t make any changes to support the new “Assistant APIv2” or “vector store” yet, since this is the first time I’m hearing of it.

Join the unofficial Make Discord server to chat with other makers!

2 Likes

I was just gathering the bundles and suddenly OpenAI returns with a successful output. So I guess this was in OpenAI’s end all the time.

However, migrating to assistants api v2 would be useful. Here’s the doc: https://platform.openai.com/docs/assistants/migration

2 Likes

Thanks for the assistants upgrade link, I’ll take a look into it!

In the meantime, If the external service has a Developer API Reference/Documentation then you should be able to integrate the endpoints in Make using the app’s universal module (Make an API call) or generic HTTP “Make a request” module.

You can also suggest for it to be made in the Idea exchange. Don’t forget to search for it first, just in case someone already suggested it, so that you don’t end up creating a duplicate.
Screenshot_2024-01-17_130153

If you need assistance in setting up the app’s universal module, or the generic HTTP module, please provide additional information about what you have tried with regards to the external service’s Developer API Reference – how you are setting the connection up, a link to the endpoint are you trying to connect to, and what errors you are encountering.

You can also complete this brand new course/tutorial in the Make Academy on how to use external APIs — API calls with HTTP modules

  • API and Endpoints
  • Header and body
  • Multipart/form-data
  • OAuth 2.0

Join the unofficial Make Discord server to chat with other makers!

1 Like

Adding on to this thread. It looks like the new GPT-4o model requires an HTTP Header parameter to be passed through when using v2 of the Assistants API. The current Make integration doesn’t allow changing HTTP Headers.

Is this something that could be changed to allow headers to be passed or the v2 API to be used?

Thanks

5 Likes

I have same question here.

1 Like

Same here ! We can’t use an API assistant with 4o model at now !

3 Likes

Same here, I double-checked if my created assistants use the v2 and they are, so I’d be curious if anybody could help! Thanks in advance.

3 Likes

Same here. Assistants with 4o are a no go at the moment. Hope Make fixes the integration soon

2 Likes

Same here! Waiting for Make to fix this…

Same, this seems to be an open issue right now.

Same here. I am getting the message “The operation failed with an error. [400] The requested model ‘gpt-4o-2024-05-13’ cannot be used with the Assistants API in v1. Follow the migration guide to upgrade to v2: https://platform.openai.com/docs/assistants/migration.

However, my assistant is using API V2. and so I will default to the turbo for now…

I also spotted that they have renamed “retrieval” to “file search” and so that feature is not working at present…

same here Waiting for Make to fix this…

Hello everyone @here

I just want to confirm that this is unfortunately a known issue of the “4o” model. Our dev team is aware of this and is working on updating our ChatGPT module to the latest API version.

We will let you know once the update is rolled out.

Thank you very much for your patience and understanding. :pray:

As a temporary workaround, you could use an older assistant model or use the “Make an API Call” module with the custom API call to OpenAI API with the “OpenAI-Beta: assistants=v2” header.
The below guide might provide general help on how to use the “Make an API Call” modules.

:arrow_right: How to make an API call: tutorial

2 Likes

Hello, thank you for the answer, regarding the old versions, I tried and it’s the same thing, the problem with the version of the assistant, when I send my request I get the error that appears even though before the update I used exactly the same wizard and everything worked correctly

We update the makemarket open ai modules to support GPT-4o and functions. give it a look. Check this post for more details: Open AI Assistant Module with GPT-4o and functions